ZTree.com  | ZEN  | About...  

 Index   Back

[Bug] Deleting Viewed File During Ctrl-View Sequence   [Bug]

By: VWheeler     Denver, Colorado, USA  
Date: May 15,2016 at 01:35
In Response to: [Bug] Deleting Viewed File During Ctrl-View Sequence (Andreas Boehlk)

> > Hello!
> >
> > Platform: Windows 7 64-bit
> > Version: v2.4.145 (I don't know how to get v2.4.164, so I have not
> > tried it in that version).
> >
> > In getting to know ZTreeWin's features, I created 3 simple files in
> an
> > empty directory, tagged all 3 of them, and then hit Ctrl-V(iew). The
> > viewing went as expected and I could move to the [N]ext and
> [P]rev(ious)
> > files as expected. However, there is a feature where you can hit the
> > [DELETE] key during this viewing and it appears to be intended to
> delete
> > the file viewed (based on the feature entry for Beta version
> v2.4.113:
> > "Added - View/Ctrl-View - Del - Delete viewed file").
> >
> > In case this is pertinent, the file names were:
> >
> > hello.txt,
> > hello2.txt, and
> > hello3.txt
> >
> > each with recognizable content so I knew which file was being viewed.
> >
> > Regardless of what file was being viewed, when I hit the [DELETE]
> key,
> > the confirmation prompt offered to delete whatever file was
> previously
> > current before the Ctrl-View sequence began. This does not look like
> the
> > intended behavior.
> >
> Hello,
> I just tried it with the current version and the behaviour was as
> expected.
> So I suggest that You download it and have another try.
> The link can be found a little bit further down in this forum , where
> Kim announced this latest version i.e. 2.4.166.
> Good luck with that!
> Andreas

Hi, Andreas!

Shortly after I posted this, I saw Kim's posting of the availability (and link to) v2.4.166, so I downloaded it, installed it, and tried my test again and still got the same behavior. Per Kim's request (he requested bug reports be reported as responses to his message), so I updated this report there with the version tested being v2.4.166.

I am running ZTW64.EXE modified 01-May-2016 18:53:36 (my time, as extracted from the v2.4.166 zip file), 1,108,456 bytes having an MD5 hash of "6ad14c72d403fe7646bbb06e8d7ce75f".

I posted a screenshot there testing with 3 files showing the results after pressing the [DELETE] key.

However!!!! Now I cannot replicate the problem, and in fact since I last tested it, I have changed a number of settings.

What's more, I just put back the old ZTW64.EXE and now it is not happening with THAT version either. Conclusion so far: the problem isn't being triggered with my current settings / setup / environment..... not sure what it is yet, but I'll work to try to restore the environment I had yesterday when I reported this (and after I installed v2.4.166) to see if I can replicate the problem and then will report back here.

I will place this information with my posting as a response to Kim's post as well.

Will report back here soon. :-)

Kind regards,
Vic

413 views      
Thread locked
 

Messages in this Thread

 
94,426 Postings in 11,918 Threads, 348 registered users, 9 users online (1 registered, 8 guests)
Index | Admin contact |   Forum Time: Sep 18, 2019 - 5:56 pm EDT  |  Hits:28,649,220  (1,967 Today )
RSS Feed