ZTree.com  | ZEN  | About...  

 Index   Back

my head ignored "call" in all batches.....   [Q]

By: Ryan       
Date: Aug 29,2017 at 21:57
In Response to: adding 1 more %, doubling it, still dont work, so i was wondering if it was bug (Nick Williams)

> > SET "P1=AAAABBBBBBBB DDDDDDDDDDDDDDDDDAAAAAAAAAAAAAAAAA"
> > SET "N=20"
> > CALL ECHO:%%P1:~0,%N%%%
>This example I gave you, definitely works. Have you actually tried it ?

worked

> BB=works in command line (i meant as in batch)
> SET P1=AAAABBBBBBBB DDDDDDDDDDDDDDDDDAAAAAAAAAAAAAAAAA
> SET N=20
> ECHO %%P1:~0,%N%%%
> it worked in a batch, so it must work in F9(=ztreemenu script)... but
>This could not possibly have worked, for 2 reasons:-
>(1) As I've already said,

it didnt work
-----------------------

i am really sorry about this
i tried with many batches, and it is a strange reason, but it seems to be the season
when nothing was sure in my head.

my brain simply ignored the word "call" in all batches, as if it was never there.
huh? where did this call come from? is the state i am in now.
now i realized everything was mixed, the ones that worked had "call" in them
i copy-pasted to test it, but then i wrote them or copy-pasted in a different syntax, i must have removed call when removing ">"

i wasted your time, i am really sorry about this.

259 views      
Thread locked
 

Messages in this Thread

 
94,494 Postings in 11,923 Threads, 348 registered users, 8 users online (1 registered, 7 guests)
Index | Admin contact |   Forum Time: Oct 22, 2019 - 3:09 pm EDT  |  Hits:28,794,641  (3,185 Today )
RSS Feed