ZTree.com  | ZEN  | About...  

 Index   Back

[Help!] How do avoid this ?   [Help!]

By: Ben Kent       
Date: Apr 06,2018 at 17:59
In Response to: [Help!] How do avoid this ? (Laurent Duchastel)

> When ZTree windows snaps to monitor border and get back to window
> mode, I always get this:
>
>
>
> Which settings in Properties to set ?
>
> I don't want legacy console mode as it has display issues of its own.
>
> Thank you

Laurent

Try

Properties
Layout tab
untick "Let system position window"
Set the position you like

I suspect you are running Windows 10, so someone who is running that OS might be able to give some better advise.


Windows 10 intruduces consoles that wrap when resized, like *nix ones do.

Read https://blogs.windows.com/buildingapps/2...-in-the-windows-10-technical-preview/ the GUI has changes a bit but the post describes the things that have changed.

Set this to turn off the new features for all consoles

[HKEY_CURRENT_USER\Console]
"ForceV2"=dword:00000000

From a quick check on a Win10 machine I have access to, it seems that there is no way to adjust the setting per console.

You might need to append /kALT_F7 to your ZTree command line.

If the issue is that ZTree is not handling the console being dynamically resized, then maybe you should ZEP for ZTree to respond to the console resize APIs, like unixtree on Linux does.

Ben

394 views      
Thread locked
 

Messages in this Thread

 
94,578 Postings in 11,930 Threads, 348 registered users, 16 users online (0 registered, 16 guests)
Index | Admin contact |   Forum Time: Nov 12, 2019 - 7:05 pm EST  |  Hits:29,077,601  (6,776 Today )
RSS Feed