ZTree.com  | ZEN  | About...  

 Index   Back

[OT] Need SMBv1 on Win10 to work with XP and 8.1   [OT]

By: Ron Metzger       
Date: Nov 27,2018 at 22:46
In Response to: [OT] any utility from NirSoft that can disable or enable wifi in command lines? (Ryan)

> Hi
>
> does anyone know any utility software from NirSoft that can disable or
> enable
> wifi or lan adapters from the command lines? because XP does not work
> "netsh interface name..." command, because the network interface names
> for XP were strickly hidden, they said. if DevCon just does this with 1
> Gbyte installation, I can not use this DevCon.exe.
>
> My XP and Win 8.1 can recognize each other and share files, but my
> win10 does not give its files to XP or win 8.1. my XP and Win8.1 said
> that the host(win10) was refusing without the password. I have done
> everything I know in win 10 to share files with other PC's. Are there
> any pointers that might help me with few words? finding the answer in the
> internet has not worked so far.

Ryan,

This could be because Server Message Block v1 (SMBv1) is not active on Win 10 and needed to work with Win 8.1 and XP. Win 10 r1709 and later does not install SMBv1, but previous versions upgraded to r1709 or later will maintain SMBv1. Fresh r1803 for example, will not install SMBv1.

See: SMBv1 is not installed by default in Windows 10 Fall Creators Update and Windows Server, version 1709 and later versions https://support.microsoft.com/en-us/help/4034314/smbv1-is-not-installed-by-default-in-windows

To Enable SMBv1 on Win 10:

Start > PC Settings > Apps > Apps & features > Programs and features
> Turn Windows features on or off
Locate and expand [+] SMB 1.0/CIFS File Sharing Support
Check:
SMB 1.0/CIFS Automatic Removal
SMB 1.0/CIFS Client
(and if hosting on Win 10, accessing from XP)
SMB 1.0/CIFS Server

Select OK
Restart PC.

Once restarted:
Start > PC Settings > Network & Internet > Network and Sharing Center
Select the adapter under Connections:
Select Properties:
Select Internet Protocol version 4 (TCP/IPv4) > Properties
Select Advanced...
Select tab WINS
Under NetBIOS Setting
Select Default:

Finally, create a SMBv1-On.reg file

REGEDIT4

;; To enable or disable SMBv1 on the SMB server
;; SMB1=1 Enabled, Default
;; SMB1=0 Disabled
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters]
"UseOpportunisticLocking"=dword:00000000
"SMB1"=dword:00000001
;; "SMB1"=dword:00000000

and Open SMBv1-on.reg from ZTreeWin

Restart PC.

This should enable NetBIOS over TCP/IP and allow connections to Win XP and most Samba Share systems.

Be Warned that SMBv1 has been deprecated and is not recommended by Microsoft due to security issues that cannot be solved.

See: Microsoft Security Bulletin MS17-010 - Critical

Hope this helps.

Ron Metzger

81 views      
 

Messages in this Thread

 
93,933 Postings in 11,850 Threads, 347 registered users, 7 users online (2 registered, 5 guests)
Index | Admin contact |   Forum Time: Dec 10, 2018 - 12:55 pm EST  |  Hits:26,925,839  (2,307 Today )
RSS Feed