ZTree.com  | ZEN  | About...  

 Index   Back

[Help!] Skip UAC Running ZTW (Admin)?   [Help!]

By: Andrew Penfold     Hampshire, UK  
Date: Jun 12,2019 at 14:48
In Response to: [Help!] Skip UAC Running ZTW (Admin)? (Steven James)

> Well, this is something. It appears that I've overlooked quite a bit
> (for how long, I do not know). First, I must admit that I'm not a
> Windows administrator (by hobby or profession). So here is what I did: I
> adjusted the User Account Control settings to each level (they were
> initially set to Default -- the second highest level [3 = Highest, 0 =
> None]). I then successively opened a range of applications as
> Administrator (i.e. Run As Admin).
>
> NONE of them prompted me with a UAC dialog irrespective of level. I
> then launched several other applications: 1) as merely User, and 2) as
> Administrator. Nothing. Finally, I opened the file location for ZTreeWin
> (ZTW.EXE and ZTW64.EXE) and ran them 1) as User, and 2) as Admin. I did
> the same with the Console or CMD. No UAC prompts.
>
> I am at a loss to explain this behavior. My preference has generally
> been to sacrifice convenience at the expense of security, but not
> ridiculously so. Thus, my choice of 2 for the default setting. Until
> now, I have not noticed this UAC behavior (not prompting me at elevated
> privilege). So, I'm as confused about this as anyone. As I said, I'm
> not an expert at UAC or other administrative features, but I suspect
> there is another setting somewhere that is circumventing the UAC setting
> entirely. Other than that, your guess is as good (or likely much better)
> than mine.
>
> Thank you for the ghacks.net link. This should resolve my initial
> request for a fix to skip Windows 10 UAC prompts.
>
> SJ


If you are logged into Windows as BUILTIN\Administrator, then by default, UAC prompts don't appear. All processes you run are running with full administrative privileges. This can be overridden by a group policy setting (Start --> Administrative Tools --> Local Security Policy --> Local Policies --> Security Options --> User Account Control: Admin Approval Mode for the Built In Administrator Account). Enabling this means the built-in Administrator account will get UAC prompts.

However, you have said that you launched several applications, including some as a standard user, so that implies that you were logged into Windows as a standard user to begin with.

Or maybe you are logged into Windows as an admin (not the built-in one) but the policy "User Account Control: Run all administrators in Admin Approval Mode" has been set to Disabled.

Just some things to check.

118 views      
 

Messages in this Thread

 
94,417 Postings in 11,916 Threads, 348 registered users, 5 users online (1 registered, 4 guests)
Index | Admin contact |   Forum Time: Aug 22, 2019 - 9:14 pm EDT  |  Hits:28,555,903  (4,702 Today )
RSS Feed