ZTree.com  | ZEN  | About...  

 Index   Back

[Bug] zlog corruption (and a workaround?)   [Bug]

By: John Leslie       
Date: Jan 25,2020 at 12:38
In Response to: [Bug] zlog corruption (and a workaround?) (John Leslie)

> > > The thing that I'm noticing now is that the corruption might
> only
> > be in the
> > > history items, and not the file structure items, so unlogging
> > couldn't release
> > > the corrupted parts if that were the case.
> >
> > Exactly. The main logged structure had been very reliable for years
> > until history list were appended in a new revision of the zlog file
> > format.
> >
> > You mentioned the corruption was in the second set of save paths,
> which
> > is not the F11 bookmark history, but actually a reference to a
> current
> > file in each logged directory. The real puzzle now is why the
> unicode
> > paths randomly not being serialized correctly...
>
> I don't think this is the case, as I was able to release directories
> and save a "good" ZLog when I had previously been saving "dud" ones.
> What I wasn't able to do was tie it down to a particular directory
> (despite many hours of trying)...
>
> I have found saving ZLogs (well, strictly loading them) very unreliable
> for a long time (see my previous reports in response to ZTree
> releases)...

E.g.
http://www.ztw3.com/forum/forum_entry.php?id=121014
http://www.ztw3.com/forum/forum_entry.php?id=121049
http://www.ztw3.com/forum/forum_entry.php?id=121459
http://www.ztw3.com/forum/forum_entry.php?id=121491
http://www.ztw3.com/forum/forum_entry.php?id=122761
etc.

78 views      
 

Messages in this Thread

 
94,748 Postings in 11,945 Threads, 348 registered users, 16 users online (0 registered, 16 guests)
Index | Admin contact |   Forum Time: Feb 17, 2020 - 5:42 am EST  |  Hits:30,033,175  (2,272 Today )
RSS Feed