ZTree.com  | ZEN  | About...  

 Index   Back

Need more info   [Bug]

By: Liviu       
Date: Mar 02,2020 at 03:19
In Response to: Need more info (Kim Henkel)

Don't know that it's related, but I'll leave this here maybe it helps in some way.

I had a .zlog just saved which fails to open with "Error: Invalid volumes file - cannot load". It is a big zlog (close to 3GB) but all files are logged on a single volume (B:\ which holds symlinks to other local and remote targets, all accessible).

> The end of the file contains 2 sets of saved paths, separated by the
> characters 'ZV' (0x5A 0x56). Can you confirm the corrupted path is in
> the first of these blocks?

My zlog ends with the following (where I notice a single-byte 0A right after ZVZV)...

AE028F20 00 00 00 00 00 0A 00 5A 56 5A 56 0A 2A 00 2E 00 ·······ZVZV·*·.·
AE028F30 2A 00 0A 00 0A 00 01 00 04 00 03 00 42 00 3A 00 *···········B·:·
...
64 more bytes here, which look like a valid UTF16-LE path plus "0A 00 00 00"
...
AE028F80 5A 56                                             ZV

Reading the other posts here, I tried and removed the 85 bytes between the ZVs so that the file ended with ZVZVZV, but it still gave the same error when trying to load. I then removed the trailing ZV pairs one by one, still no luck.

> Also can you check if the list shown with F11 matches what is saved in
> the file, and if you ever see such corruption in that popup list?

On a fresh run, an F11 right before loading the zlog shows just one directory (where the zlog is), on a drive which is not referenced anywhere in the zlog.

Cheers,
Liviu

100 views      
 

Messages in this Thread

 
94,976 Postings in 11,969 Threads, 349 registered users, 28 users online (1 registered, 27 guests)
Index | Admin contact |   Forum Time: May 28, 2020 - 12:10 pm EDT  |  Hits:31,250,249  (3,500 Today )
RSS Feed