ZTree.com  | ZEN  | About...  

 Index   Back

Error message 800A0005   [Help!]

By: Ben Kent       
Date: Apr 18,2020 at 13:27
In Response to: Error message 800A0005 (Robert Baguley)

> I am setting up a development environment on a new laptop, with
> Windows 10 Pro 64-bit 1903 this time.
>
> When I run ZTWMenuText.vbs with the /A parameter, I get an error
> message. I have looked on the web but not found anything helpful.
>
> As far as I know I am using the latest version of ZTWMenuText.vbs
> (version 1.0.0.12).
>
> Has anyone here seen something similar please, and could give me a
> pointer as to what I am doing wrong ?
>
> Script: C:\ZTreeWin\ZTWMenuText.vbs
> Line: 691
> Char: 5
> Error: Invalid procedure call or argument: 'Asc'
> Code: 800A0005
> Source: Microsoft VBScript runtime error
>
> The line in question seems to be
> nLevel = Asc(Mid(sInFile, nStartPos + 2, 1)) ' Menu level
>
> If I run the script with the /A /M parameters, the error does not
> occur.
>
> I downloaded some Application Menu files posted here by Laurent many
> years ago, but received the same error message. So I don't think my
> menu file ZTW.ZAM is corrupted or malformed.
>
> There is talk on the web of a bad Microsoft patch affecting VB Script,
> but it was long time ago and I think it has been fixed in the meantime.
>
> Any pointers would be gratefully accepted.


The only time I have seen Asc() go bang is when there are extended characters and it gets interpreted as a unicode character that the ansi Asc() function cannot handle.
There is a AscW() function, but the definition of the ZTree menu file limits the levels to 128, so that shouldn't be a problem, and Laurent's wouldn't have deep levels.

Some thoughts
Please upload one of the files you are having an issue with, but as you state the issue seems to be elsewhere.
What codepage, region, etc to you have?
Do you only see the issue on one machine?
Have you tried creating another user account on the problem machine, to see if the script works with that user.
Do a full AV scan with your normal scanner, and with a secondary, I use https://download.eset.com/com/eset/tools...ine_scanner/esetonlinescanner_enu.exe as my secondary scanner.

I tested on Windows 8.1 and Windows 10 1903 here and no problems.

I have put some error catching around the Asc() calls and added a verbose option.
I don't expect it to fix the issue, but might give us some clues.

Please download from http://www.ztw3.com/upfile/ztwmenutext13.zip
and run with /a /v then the logging might give a clue to where in the ZAM file is causing the problem.


Ben

81 views      
 

Messages in this Thread

 
94,977 Postings in 11,970 Threads, 349 registered users, 42 users online (0 registered, 42 guests)
Index | Admin contact |   Forum Time: May 30, 2020 - 9:46 am EDT  |  Hits:31,266,614  (3,139 Today )
RSS Feed