ZTree.com  | ZEN  | About...  

 Index   Back

[Q] F9 Menu Script Assistance   [Q]

By: GoSlow2GoFast     RI  
Date: Aug 19,2022 at 11:01
In Response to: [Q] F9 Menu Script Assistance (Dan LeGate)

> Not very experienced in this arena (F9 Menu), so I have no idea why
> this script is always going to the "requires tagged files" message even
> with there are tagged files when I launch it? (tried to follow the F1
> help docs)
>
> SET ZTTagged=False
> REM #ZTIfTagged SET ZTTagged=True
> IF [%%ZTTagged%%]==[False] GOTO Err_NoTag
> REM mkdir %4
> REM C:\Users\dx7668\Documents\ztw\pkzipc.exe -extract %1 .\%4
> :Err_NoTag
> ECHO This menu item requires tagged files to operate
> Pause
> :End

It looks like there are two possibilities. If you don't have a file tagged then it will produce that message. In addition, even if there is a file tagged, there is no GOTO before the :Err_NoTag label, so the script will execute the lines:

REM mkdir %4
REM C:\Users\dx7668\Documents\ztw\pkzipc.exe -extract %1 .\%4


And then proceed down to the display message you are seeing. You probably want to add the GOTO like below, depending on what you are trying to accomplish.

SET ZTTagged=False
REM #ZTIfTagged SET ZTTagged=True
IF [%%ZTTagged%%]==[False] GOTO Err_NoTag
REM mkdir %4
REM C:\Users\dx7668\Documents\ztw\pkzipc.exe -extract %1 .\%4
GOTO End
:Err_NoTag
ECHO This menu item requires tagged files to operate
Pause
:End

85 views      
 

Messages in this Thread

 
95,961 Postings in 12,120 Threads, 350 registered users, 43 users online (0 registered, 43 guests)
Index | Admin contact |   Forum Time: Sep 26, 2022 - 9:19 am UTC  |  Hits:50,903,775  (8,563 Today )
RSS Feed