ZTree.com  | ZEN  | About...  

 Index   Back

[BETA] v2.4.199 Now Available!   [BETA]

By: RGKnott       
Date: Jan 03,2021 at 04:01
In Response to: [BETA] v2.4.199 Now Available! (Kim Henkel)

Installed v2.4.199 on Windows10 32bit v1909 (OS Build 18363.1256) NTFS, and I decided to update ARCHIVER.BB2 for 7-Zip 19.0. I used examples found in this forumn, mostly by Colin Liebenrood -- which were for 7-Zip 16.0 but thank you -- and the 7-Zip 19.0 documentation to see if the switches are still valid. But I've no clue about the format for line 1. Like [LFN,UNICODE,NAP]. Someone else said always use [LFNU NAP] for 7-Zip so I tried that at some point.

This post is pertaining to this workaround for the long-time issue with Alt-F5 Open archive. . .

"NOTE: If ZTreeWin appears to have frozen after invoking
Alt-F5, it may be that the called external archiver
is awaiting the input of a password (for encrypted
headers). In this case, you may simply type the
password and Enter to continue."

That no longer works. When I finally interrupt the "freeze" by pressing Ctrl-Z two or three times, this message pops up:

Archive Cannot be Accessed
Return Code: [2]

File ...\ZTMP000\ZTW.$$$ contains:

7-Zip 19.00 (x86) : Copyright (c) 1999-2018 Igor Pavlov : 2019-02-21

Scanning the drive for archives:
1 file, 52809570 bytes (51 MiB)

Listing archive: C:\Temp\Sheets.7z

Enter password (will not be echoed):

Errors: 1

It doesn't matter how long I wait, or how many times I enter the password and enter while ZTW is spinning. It doesn't work anymore. I know it did before at some point, but I can't say when that was. Quite some time ago to be certain.

C:\Temp\Sheets.7z was archived from the command line with -p and -mhe switches.
I created the archive again only without the -mhe switch. When I removed the -mhe switch ZTW opens it fine, displays the tree and files and prompts for password only when accessing a file, as it probably should. Then I added the -mhe switch to ARCHIVER.BB2 (because I want to encrypt the filenames). Next I recreated the same archive using ZTreeWin Ctrl-F5 and Encryption. No problem doing that and 7-Zip opens the archive just fine. But ZTreeWin cannot! It has the same Alt-F5 problem.

So by now my Archiver.bb2 looks like this: (Oh, and I also moved this section to the top, before the other Archiver.bb2 entries).

; This entry is for 7-Zip 19.0
; Full paths are not supported in Global mode, as drive letters are omitted by
; the [NAP] switch (http://sourceforge.net/forum/message.php?msg_id=2956956).
; Saw nothing pertinent there. Searched whole project for NAP switch: Nothing.
; Add '-mx9' to the 'a' add lines for maximum compression,
; '-mx=0' to store the files without compression,
; '-mx=5' is normal default, '-mx1' is fastest.
; Add '-ms=off' to the 'a' add lines to turn off creation of solid archives
; which allows individual files to be deleted inside the archive afterwards.
; Add '-stl' to set archive timestamp from the most recently modified file.
; Add '-mta=on' stores the last accessed timestamps.
; Add '-mtc=on' stores the created timestamps.
; Add '-mhe' to encrypt archive headers, so filenames will be AES encrypted.
; If -mhe switch was used to create archive, then ZTreeWin cannot access it.
; Visit http://www.7-zip.org
; 7-Zip 19.0 for 7z [LFNU NAP] I guess this has this been superseded?
7-Zip 19.0 for 7z [LFN,UNICODE,NAP]
%ProgramFiles%\7-Zip\7z.exe l -sccUTF-8
%ProgramFiles%\7-Zip\7z.exe e -y
%ProgramFiles%\7-Zip\7z.exe x -y

%ProgramFiles%\7-Zip\7z.exe a -mhe -ms=off -mta=on -mtc=on -stl @list
%ProgramFiles%\7-Zip\7z.exe a -mhe -ms=off -mta=on -mtc=on -stl @list

%ProgramFiles%\7-Zip\7z.exe d @list
------------------- ----- ------------ ------------ ------------------------
------------------- ----- ------------ ------------ ------------------------

7-Zip is not in my CMD environment %PATH%, but apparently specifying the fully qualified pathname obviates that requirement. I watched to be sure both the Ctrl-F5 and Alt-F5 operations used this archiver.bb2 section. (Of course when the Alt-F5 problem occurs it never gets far enough to show the "7-Zip 19.0 for 7z [LFN,UNICODE,NAP]" message displayed). I verified the file contains the signature, e.g., 00000000 37 7A BC AF 27 1C. I also tried adding back the -sccUTF-8 to line 4.

Always the same result; 7-Zip can process the output file just fine, but ZTW doesn't accept the password and says it cannot access the archive.

When I remove -mhe from ARCHIVER.BB2 everything seems to be AOK with ZTW created encrypted archives. ZTW can access them. But as I said, I still want to use that option.

This probably might not have anything to do with the latest beta in particular. Since I don't know when the last time Alt-F5 Open archive worked for me in this scenario. Notice I didn't say, "I cannot remember the last time..." If you say you "can't remember" too often, people assume you are senile. Then they do things like take away your car keys from you and warehouse you in an old-folks home.

Live long and prosper,


Messages in this Thread

95,371 Postings in 12,032 Threads, 350 registered users, 57 users online (0 registered, 57 guests)
Index | Admin contact |   Forum Time: May 8, 2021 - 3:43 am UTC  |  Hits:39,369,478  (2,712 Today )
RSS Feed