ZTree.com  | ZEN  | About...  

 Index   Back

Mystery Solved!   [Zeta]

By: Ben Kent       
Date: Jun 06,2022 at 23:08
In Response to: Mystery Solved! (John Gruener)

> I just tried moving these files with Win Explorer. It of course
> informed me I had to give it Admin privileges, which I did. There was a
> brief progress bar as if some processing had to take place as the files
> were moved. I then inspected the permissions, only to find they are very
> different from when moved by ZTree. The Security tab Advanced screen
> shows my user login as having full control, which is confirmed by Hex
> Editing them with non-Admin ZTree. But it says that full control is
> inherited from "C:\Program Files", which is clearly not the case.
> Without Admin I cannot create or update anything else under "C:\Program
> Files". Very strange.


Windows explorer is coded to never elevate, when it asks to elevate to copy/move a file, what is does is grant you rights on the destination, so you end up with messy permissions.

To get the equivalent behaviour as you got with the elevated ZTree, you should use an elevated cmd window and the move command.



Note
This can change the behaviour of explorer when elevation isn't needed, so would not make any difference in your case
reg.exe Add "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer" /v MoveSecurityAttributes /t REG_DWORD /d 0 /f

535 views      
 

Messages in this Thread

 
96,640 Postings in 12,231 Threads, 350 registered users, 67 users online (0 registered, 67 guests)
Index | Admin contact |   Forum Time: Apr 12, 2024 - 3:27 pm UTC  |  Hits:62,818,751  (14,282 Today )
RSS Feed