ZTree.com  | ZEN  | About...  

 Index   Back

[Bug] Strange external viewer behavior.   [Bug]

By: Dave Gordon       
Date: Jan 18,2024 at 19:04
In Response to: [Bug] Strange external viewer behavior. (Kim Henkel)

Thank you Kim, adding the %1 solved the issue.

My external viewer command was:
"C:\Program Files\zabkat\xplorer2_ult\editor2_64.exe" /M /V /P

It has always worked, with several different editors and viewers, without the %1.

Adding the %1 and it works. No "", and paths / filenames with spaces work.
"C:\Program Files\zabkat\xplorer2_ult\editor2_64.exe" /M /V /P %1

I also added Start "" to the line:
Start "" "C:\Program Files\zabkat\xplorer2_ult\editor2_64.exe" /M /V /P %1

This has solved another oddity, which I always assumed was related to my external viewer. If I used the internal viewer, or the help file, followed by the external viewer I got the message "Search forward from current location:" in the ZtreeWin Menu and Commands area. Hitting any key (I usually hit "v" again, or the space-bar) cleared the message and the viewer worked.

I use Start "" and %1 in my Ztree applications menu, I never thought to use them in the external viewer command.

225 views      
 

Messages in this Thread

 
96,664 Postings in 12,235 Threads, 350 registered users, 234 users online (0 registered, 234 guests)
Index | Admin contact |   Forum Time: Jun 22, 2024 - 6:04 pm UTC  |  Hits:65,461,743  (85,548 Today )
RSS Feed